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1

Introduction
An ePro BioClock provides an advanced method of recording employee attendance by using
fingerprint scans for identity verification. A BioClock can be used as a standalone system or it
can communicate with the ePro Scheduler scheduling, time & attendance and payroll system. If
using an ePro BioClock as a standalone system, disregard directions and references to ePro
Scheduler. All of the data needed for payroll can be viewed, imported, or printed from the
BioClock Administrator software.
ePro BioClocks collect employee punches on the computer where the fingerprint scans occur.
Punches can be uploaded to the server manually, using the administrator software, and
automatically at regular intervals. Fingerprint enrollment creates a database of scanned
employee fingerprints for attendance recording purposes. The fingerprint scans can be
synchronized to the ePro Scheduler server manually by using the administrator software or
automatically once per day. The synchronization allows fingerprint scans to be downloaded by
other ePro BioClocks at remote locations.
The ePro BioClock software is a Windows application that has been validated for Windows XP
and Windows 7 (32 bit and 64 bit) operating systems on Pentium based computer systems with
the following minimum system requirements:
Windows XP, Vista and Windows 7
CPU: 300 MHz or Pentium-compatible higher processor
OS: Windows XP, Vista and Windows 7 (32 bit and 64 bit)
Memory: 512 MB RAM; more memory improves performance
Hard Disk: 1.5 GB of available hard disk space

2

Installation
The ePro BioClock installation procedures are documented in the installation guide included on
the installation CD. The ePro BioClock system is ready to use following installation. The
Administrator can be launched from the Start menu program group. The Administrator Help
contains all the instructions needed to use ePro BioClock. Launch the ePro BioClock
Administrator and configure the software (see next section).
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3
3.1

ePro BioClock Administrator
Administrator Panel
The administrator interface is password protected. However, on initial use no password is
required. To log in, simply click submit. Once logged in, all of the administrative functions are
available.

The administrator panel provides access to all administrative functions. The main scrolling
window is a run-time log that is updated when commands are executed. The pull-down menus
provide access to administrative functions.
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3.2

Configuration Setup
Configuration setup is required to facilitate communication with the ePro Scheduler server. The
server identification will ensure that punches are stored in the correct database. The master
enrollment is also stored in the database and can be downloaded to any ePro BioClock in the
field. To access the setup panel click the “Configure ePro BioClock” selection on the Tools menu.

Once the setup panel is launched, the BioClock can be configured.
Important Note

Call eCore at (866) 240-6996 to get the settings to allow the ePro BioClock to
communicate with your ePro Scheduler.
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ePro BioClock Name
A unique name is assigned to each ePro BioClock installed. A single ePro Scheduler database
can support one or more remote BioClocks. The ePro BioClock name must correspond to an
ePro Scheduler Kiosk name as entered on the Manage Timekeeping -> Setup Kiosks panel in
ePro Scheduler for the names to be displayed on the daily timekeeper logs.
Server ID and Server Location
The Server ID identifies the ePro Scheduler associated with the installed BioClock. The server
location is the URL that identifies the remote server connection location. The ePro BioClock will
not be able to communicate with ePro Scheduler server unless these fields are properly
configured.
Call eCore Software Inc. at (866) 240-6996 to get these fields.

Administrator Password
To set a password to access the Administrator Panel, type a password into the field labeled
“Administrator Password.”
Operational Mode
ePro BioClocks can be configured to run in the following three modes:
1) PIN: Employee enters Employee ID as Personal Identification Number (PIN) for fingerprint
lookup and verification.
2) One Touch: Fingerprint is looked up and used to find the employee enrollment information
in the ePro BioClock database. When a match is found, the employee can punch in/out
with no further action unless required to enter a comment (default).
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3.3

Manual Punch Entry and Deletion
An ePro BioClock provides an excellent standalone solution if the Internet interface provided by
eCore is not used. In and Out punches can be entered manually from the „Manual Punch‟ submenu on the Tools menu. Punches (both in and out) can be entered by clicking the „Entry‟ menu
item. Punches can be deleted by clicking the „Deletion‟ menu item.
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3.3.1

Manual Punch Entry
Enter a punch by selecting an employee from the employee pull-down. Select the time and date
for the punch, then click the IN or OUT button. The punch will be recorded in the database.

3.3.2

Manual Punch Deletion
To delete a punch, select an employee and the date span the punch is included in. Display all
punches in the date span by clicking query. Select the punch to be deleted from the punch list,
then click the delete button. The punch will be deleted from the database.
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3.4

Local Clock Setting
ePro BioClocks use the onboard system clock for recording in and out punches. Therefore, it is
very important that the local clock is synchronized with the master clock on the ePro Scheduler
server. Clocks can be synchronized using the NTP service to an external source if a live Internet
connection is available. If the onboard PC clock is to be used standalone, ePro BioClocks
provide clock synchronization with the server master clock. The clock sync requires a live
Internet connection.
Select "Sync To Master Clock" under the Tools menu. The BioClock will then request the master
time from the central ePro Scheduler server. When it is received, the BioClock will update the
system clock to reflect the time received in the server response.

3.5

Interface Testing
The Tools menu also provides interface testing to ensure that the required interfaces are working
properly. When “Test Server Connection” is selected from the Tools menu dropdown,
communication is established to the ePro Scheduler server. The "Test Server Connection"
function requires a live Internet connection. The Server Identifier is used to check connectivity to
an ePro Scheduler database.
The Test Fingerprint Scanner checks for an attached fingerprint scanner device.
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4

Enrollment

4.1

Employee Enrollment
Each employee must be enrolled at an ePro BioClock before punching in or out. To access the
enrollment function, click on the Enroll item on the main menu. Here an employee record with the
employee's name, a unique username and employee id and can be created. To update or delete
an employee profile click Enroll, select an employee name from the Employees drop down list,
then click update or delete respectively.
Once the employee record is created, fingerprints can be scanned to complete the enrollment
process. The employee panel below provides enrollment record management and the scanning
and registration of employee fingerprints.

With the employee present, select the employee from the employee list and click the FP Scan
button to enable the fingerprint scan. The employee should then place his/her index finger on the
fingerprint scanner until the fingerprint scan is displayed in the scan window. Repeat three times.
After the fourth scan, the fingerprint is saved in the database and is available to the employee for
attendance recording.
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4.2

Employee Enrollment Synchronization
ePro BioClocks support employees punching in from multiple locations. To support this, the
employee enrollment information must exist in the database of every ePro BioClock installed.
ePro BioClocks support scanning fingerprints in one location, then synchronizing the records with
other ePro BioClocks. This is done through the two step enrollment synchronization process. In
step one, employee records in the local ePro BioClock database are uploaded to the server. In
step two, employee records on the server are downloaded to the ePro BioClock. When the
synchronization is complete, the employee database will reflect the current employee database
that resides on the ePro Scheduler server.
Manual Synchronization
The synchronization can be done manually by clicking “Synchronize Employees" on the File
menu. The progress of the synchronization is displayed in the status bar at the bottom of the
ePro BioClock form. The manual synchronization software should be used for systems that do
not always have a live Internet connection.

Automatic Synchronization
If Background Updates are enabled with a valid upload interval on the setup configuration form,
the ePro BioClock will automatically synchronize with the ePro Scheduler database at the
synchronization interval. The ePro BioClock computer should always have a live Internet
connection to support the automatic synchronization process.
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5
5.1

Attendance
Recording Attendance
After the ePro BioClock database has valid employee records with fingerprint scans in the
database, it is ready to record employee attendance. An Icon for the attendance recorder was
created on the desktop at installation. Double Click the icon to launch the program.
The ePro BioClock screen display will vary depending on the Operational Mode setting (see
configuration setup, page 5). Username Identification Mode requires a valid username entry and
fingerprint scan. PIN Mode requires a valid Employee ID entry for a PIN and a valid fingerprint
scan. One Touch requires a fingerprint scan only that is used to identity and employee fingerprint
in the database.
When a valid match is found, the employees can click the IN or OUT button to record their
attendance. A “Note to Timekeeper” box is provided for employees to type notes to the
timekeeper. The comments are displayed on various timekeeping and attendance reports on
ePro Scheduler.
One Touch Mode (fingerprint scan only)
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PIN Mode (PIN entry and fingerprint scan are required)

The History button launches a popup window that displays the employee‟s last 20 punches.
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Punch Recording Problem Alerts

The following error conditions may occur on an ePro BioClock because of a system error
or an incorrect local installation. Contact eCore Software Inc. if any of these problems persist.
The potential causes and resolutions follow:

The ePro BioClock successfully recorded the punch on the server. After a punch is saved on the
server, a local copy is written to a local database. The alert indicates the local database can‟t be
written to. Check the read/write permission of the ePro BioClock installation folder.
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5.2

Uploading Attendance
ePro BioClocks can be used as an extension to the ePro Scheduler integrated time & attendance
functions. Attendance is received from employees when they punch in and out at an ePro
BioClock. It is stored in a local database. The attendance data must be uploaded to the ePro
Scheduler server to be used by the integrated time & attendance software. ePro BioClocks
upload attendance records to the ePro Scheduler server. If local Internet service is unavailable
when an employee punches in, a background process will upload punches at a 15 minute interval
once the Internet connection becomes available. Punches can also be uploaded manually with
the following upload function.
Manual Upload
The upload can be done manually by clicking “Upload Punches" on the File menu. The progress
of the upload is displayed in the status bar at the bottom of the ePro BioClock form. The manual
upload software should be used for systems that do not always have a live Internet connection.
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5.3

Exporting Attendance
Attendance entries are stored in a local database when employees punch in and out. If
attendance data is needed by other software programs, it can be exported from ePro BioClocks
with this function by selecting the file menu, then clicking the Export Punches selection.
A prompt will be displayed to enter a date span for exported punches.

Click the 'Export' button to display a file selection dialog for the output file. Save the file as a
comma separated file (.csv). The file is formatted as follows:
<employee id>,<punch type>,<punch time stamp>
Where: Punch Types (1 - In Punch, 2 - Out Punch)
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5.4

Initializing the Local Database
Employee information, fingerprint scans and punch records are stored on each ePro BioClock
computer. It may be necessary to purge all data from the local ePro BioClock. If the data is
purged, the BioClock can be synced back to an ePro Scheduler database to download the most
current information. Be sure you want to run the function.

Warning: Once the data is removed from the local ePro BioClock, it can‟t be recovered.
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6

Reports
The View menu provides access to the reports provided by ePro BioClocks. See ePro Scheduler
for comprehensive time & attendance reporting and management.
Daily Punch Log
The Daily Punch Log provides a date span query of employee punches taken at the
BioClock.
Employee Punch Log
The Employee Punch Log provides a date span query of employee punches taken at
the BioClock for a selected employee.
Weekly Time & Attendance Log
The Weekly Time & Attendance log provides a single week query of employee punches
taken at the BioClock for all employees. The hours are displayed as regular and
overtime hour rollups.
Punch Upload Log
The Punch Upload Log is a log of punch uploads from the BioClock to the EPro
Scheduler server. This includes both manual and automatic uploads.
Synchronization Log
The Synchronization Log provides the synchronization history between the BioClock
and the EPro Scheduler server.
This includes both manual and automatic
synchronizations.
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6.1

Daily Punch Log
The daily punch log provides a date span query of punches taken at this BioClock. Click the
„Comments?„ checkbox to view in and out punch comments. Comments can be entered directly
by employees or by using the Manual Punch -> Entry function in the ePro BioClock
Administration program. Below is an example of the report.
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6.2

Employee Punch Log
The employee punch log provides a date span query of employee punches taken at the BioClock
for a selected employee.
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6.3

Weekly Time & Attendance Log
The Weekly Time & Attendance log provides a single week query of employee punches taken at
the BioClock for all employees. The hours are displayed as regular and overtime hour rollups.
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6.4

Punch Upload Log

The punch upload log provides the upload history of punches received at this BioClock up to the
EPro Scheduler server. Below is an example of the report.
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6.5

Synchronization Log
The synchronization log provides the synchronization history of employee profiles with the EPro
Scheduler server. Below is an example of the report.
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7

Support
ePro BioClock software and fingerprint scanning devices are provided by eCore Software Inc. to
be used with a current ePro Scheduler account. Please contact eCore if you have any problems
installing or using your ePro BioClock.

7.1

Forgot Your Password?
If the administrator password is misplaced, eCore Software Inc. can be notified to retrieve the
password using the Forgot Password form (Help menu). Fill out the name, email address and
phone number fields then click the Submit button. If your information is valid, someone from the
eCore staff will contact you by the contact information you submitted.

eCore Software Inc.
10717 Plano Rd, Suite 100
Dallas, Texas 75238
Phone: (866) 240-6996
http://www.ecoresoftware.com

- 25 -

